NCE Decoder Programming Problem with Atlas Commander : LUSENET : Wiring for DCC : One Thread

I just had a new version 3.5 SW9SR decoder professionally installed, per your instructions, with correct lighting, in a new Lifelike Proto 2000. It operates correctly in DCC mode, with correct lighting, using an Atlas Commander. However, when I try to change any of the decoder's settings with the Atlas Commander programming track, it returns error codes and doesn't change any settings. This applies to using the direct CV programming as well as page mode register programming. I've even tried putting another settable locomotive on the programming track first and then swapping to the NCE decodered SW9. Nothing works.

Could this be a defective decoder problem? Is there another way to try to program this decoder with an Atlas Commander? Is programming an NCE decoder in an Lifelike Proto 2000 SW9 known to be problematic? Should I try increasing the initial programming track voltage with DCC Specialties PowerPax DCC Programming Booster?

I really don't want to have to return the decoder as I just spent $15 to have the connections soldered and appropriate lighting added. What should I do to get this decoder to work properly?

-- Scott R. Smith (, March 13, 2005


I do not know the Atlas Commander but I am familiar with the NCE decoder your having trouble with. It sounds like the decoder is locked. NCE decoders have a feature that permits one to lock the decoder to prohibit any changes to settings. Try changing CV15 to a zero and verify that CV16 is a zero also. This will unlock the decoder allowing changes to the rest of the CV's.

-- Dan Ferrick (, March 13, 2005.

I tried the suggestion to unlock via CV15 and CV16, which I had to try to do via page mode (through changing registers to affect the CVs). Each entry resulted in an Er2 response from the Atlas Commander. While I know that even Atlas says that an error message does not necessarily mean that the entry was ignored, after further attempts to change simple settings like the decoder address, I was still unsuccessful in programming (or reading) anything on the decoder. Does anyone else have any further suggestions on what might solve this problem?

-- Scott R. Smith (, March 14, 2005.

Moderation questions? read the FAQ