My VCD won't play on My DvD player : LUSENET : Video CD : One Thread

My BUSH DVD2009 will not play VCD's. It ask's me to insert a readable disk. The manual say's that it plays dvd/vcd/cd but doesn't have a troubleshooter in it.

-- Paul Durham (, January 31, 2002


Actually, the problem most likely is that your DVD plays VCD fine, it just doesn't play VCD burned to CD-R media. Go to and look up your DVD player on the DVD player compatibility list and see what it says. CD-R media is very different from commercial VCD, DVD or audio CDs and players that support them typically require a 2nd laser beam designed just to play CD-R media. If you can't find your DVD player on this list and your manual doesn't say anything about CD-R support, then it won't play CD-R. You could try burning to CD-RW media. In a few cases some people have gotten lucky and found that CD-RW would work where CD-R didn't, but most of the time if it won't play CD-R, it won't play CD-RW either. I'm not trying to be rude, but if you buy a DVD player in the future, make sure it supports CD-R. As long as people keep buying players that don't support CD-R, some companies will never support it. It's only if their sales drop because they don't support it that they'll finally start adding support for it.

-- Jason (, January 31, 2002.

I had the same prob with panasonic dv10. Iused a vcd easy burning program which fixed the problem. The dvd is reading the wrong file. Check this out as it worked first go.

-- terri (, June 24, 2002.

bush dvd players can be a bit funny! i have one that also says it supports vcd but i couldn't get it to play one, i found an answer at - when you put in the vcd pres the "goto" button on your remote many times as quick as you can until the menu for tracks comes up and then press track 1 and your film should play. It sometimes takes two or three go's to do it but it works for me so maybe it'll help! Vix

-- vicky sampson (, December 30, 2002.

make sure the dvd player is in ntsc mode not pal, it took me ages to figure that out! and now it works :)

-- ethan trunk (, February 19, 2003.

Moderation questions? read the FAQ