Leica R7 crashed when testing selftimer

greenspun.com : LUSENET : Leica Photography : One Thread

I have huge problem with Leica R7. Iíve tested self-timer and when it should take picture only aperture have slow-downed. Iíve used A [sel.] mode and normal shutter speed. The camera doesnít respond Ė rewind crank canít move and mechanical time [100 and B] couldnít help and fresh batteries too. I have no idea why and how can repair myself.

-- Jack Zagaja (jzagaja@poczta.onet.pl), December 29, 2001

Answers

There is very little if anything you can or should try to do to self- repair an R7 more than what you ahve already done: remove, reinstall fresh batteries, try the mechanical speed, etc. I know you were hoping not to have to send it for service, but that's my recommendation. It sounds like something has jammed. BTW, be *very* careful trying to remove the lens if the aperture is stuck in the stopped down position.

-- Jay (infinitydt@aol.com), December 29, 2001.

Send it in. I had a similar thing happen to an R7 that I had for a short time, nothing works except having it looked at by a pro. Judging from your email address, Solms should be pretty close otherwise I'd send it to CRR in Luton England.

-- Dave Doyle (soilsouth@home.com), December 29, 2001.

or rather CRR ...

-- Dave Doyle (soilsouth@home.com), December 29, 2001.

Ok, so now I can only wait for an answer from Technical Division from www.leica.com . David Ė if you can check what was the cost of repairing please write it on the board immediately.

-- Jack Zagaja (jzagaja@poczta.onet.pl), December 30, 2001.

I found the way to repair. First must rotate upside down and after this pull down and right rewind crank. Apparently my body has fabric defect and hanging up and must be adjusted. This unit comes from 1994 and never be used before for this reason.

-- Jack Zagaja (jzagaja@poczta.onet.pl), December 30, 2001.


Moderation questions? read the FAQ