Elmarit 2.8/28 Diaphragm Problem

greenspun.com : LUSENET : Leica Photography : One Thread

Hello from a Leica-newbie! My small problem with the 2.8/28 Elmarit (S7-Type, bought used at E-Bay) is as follows: After having pressed the diaphragm lever of my R-E the diaphragm doesn't open to full aperture again, but it does after having pressed the shutter release. If the lens is not on the camera, there are no problems moving the diaphragm. Can't be a camera-problem, because my Summicron 2/50 and Elmarit 2.8/135 work well with the R-E. Any solutions on this list? One more question: Moving the polarizer in the square lens hood is very, very hard. (I fear I'll break my finger nails;-)) Who knows a trick?? Thanks and greetings from Germany!

-- werner musterer (contact@wernermusterer.de), November 25, 2001


The diaphragm is a puzzler, but the DOF-preview lever mechanisms on R bodies are a chronic source of sticking so I'd still suspect it even if it seems to work with other lenses. But take a look at the diaphragm tab on the lens in comparison to your other lenses...check for any malpositioning or wear that might account for the problem.

As to the polarizer, I never cared for the filter-in-hood-rotator. Get a 48-(something bigger) step-up adaptor and use a conventional rotating polarizer. If your 50 and 135 are E55 models you can get a 48-55 adaptor and use one polarizer for all 3 lenses.

-- Jay (infinitydt@aol.com), November 25, 2001.

I agree with Jay, the sticking diaphragm is most likely a camera body problem. I had the same problem with my R4sP. A CLA will fix it.

-- Douglas Herr (telyt@earthlink.net), November 26, 2001.

Moderation questions? read the FAQ