Compiler stopped compiling : LUSENET : Steve Heller's books : One Thread

I was using the compiler that comes with Learning to Program C++ and all was fine. Then one Monday I tried to debug one of the samples that was included, and upon my first press of the f8 key, it exited to DOS. It does it every time I press f8 now and it's got me confused because I didn't change anything. Any suggestions anyone? I already tried re-installing it.

-- Todd Grosvenor (, April 18, 2001


reply to compiler stopped compiling

I was using the compiler in Windows Me, and was trying to add switches to the command line and now it won't compile. It says something like "bad argument einval". I too tried to reinstall. I even erased the subdirectories, but it still doesn't work.

However, since I have more than one operating system on my computer, I decided to try to run it from Windows 98. It runs fine. It also runs in Windows 2000.

So, it appears that the compiler is actually corrupting the Windows code or registry. I don't have a solution for this yet, except I may try to erase the opsys and reinstall from scratch. This appears to be a serious defect.

-- Robert Callino (, July 04, 2001.

Moderation questions? read the FAQ