Nero problem: Scsi target problem!??? : LUSENET : Video CD : One Thread

First off, I want to thank everyone for correcting me on how to make vcd's. So now I downloaded Nero 5.0 and have it running.. but I am having a problem. When I burn a video cd it gets to 6% then states: Scsi target error then invalid writestate then could not perform endtrack.

I have an IDE-CD R/RW 8x4x32x cd-rom drive Please help!

-- P.k. (, March 03, 2001


I have the same proplem only Ive burnt around 10+ VCD no prob before then BOOM!!! Write state error.

-- Cedric Barrett (, April 12, 2001.

I have same problem. I have an IDE 16x10x32x RICOH 7163A cd r/rw and After 5 or 6 successfull burns now it always says Scsi target error then invalid writestate then could not perform endtrack. :(

When I Use its original RICOH discs. this error never happens. I tried 5 or 6 different brands of blank cdrom and got this error :( Has any body solve this problem.

-- nesim razon (, September 30, 2001.

I have the same problem. Does anybody know the answer? I think it's some sort of fault with Nero. I am in the demo mode and it says it's good for almost 2 months and it is supposed to work at full capacity. Maybe I should try Adaptec/Roxio again.

Please email me if anybody knows the answer.

-- Wilson (, October 07, 2001.

I had a similar problem, where nero reaches around 7% then it states the "SCSI target error". The solution to my problem was that I had a corrupted image/nrg file.

As to solve your VCD burning problem.

1.) copy the *.dat file to your hard drive 2.) burn the *.dat file using nero

hopefully that should fix your problem.

-- bastion (, October 14, 2001.

I'm having the same problem as well--I've been using the program for about a year, all of a sudden I get SCSI target errors no matter what I'm burning. I downloaded the latest version and still get the same errors. I'm using an HP external USB. Any help would be greatly appreciated.

-- Dave (, November 16, 2001.

I m facing this problem too. But i have burnt 50++ discs with adaptac b4 i tried using Nero. Few days ago i couldn't write anymore discs with adaptac anymore, so i decided to try Nero. But Nero gave me this same error message.

-- CH (, November 17, 2001.

I also have an IDE 16x10x32x RICOH 7163A cd r/rw and After 5 or 6 successfull burns now it always says Scsi target error then invalid writestate then could not perform endtrack. :(

Please someone help

-- David Lagettie (, December 07, 2001.

I have the same problem. After reinstalling Windows 98 and Nero, I have just been able to burn 2 CDs (I burned hundreds before reinstalling). Nero always says "SCSI Target Error", "Invalid writestate", "Could not perform EndTrack". My recorder is a 6x4x32 ACER. I found this in faqs, but am not sure whether it will solve my problem. If it does not, what other recording software do you recommend?

=== from faqs ===

Question: Although the speed test and the simulation have been tested successfully, I get a lot of error messages (SCSI-error, Host-Adapter- error..) while burning..

Answer: The problem seems to be a communication problem between the recorder and the SCSI host adapter. To solve it you have to change the BIOS settings of your SCSI host adapter. Please press Ctrl+A during booting up your PC to enter the 'SCSI Select Utility'. Then select'Configure/View Host Adapter Setting' and 'SCSI Device Configuration'. In this menu change the following parameters of the SCSI Id you have connected your recorder:

Initiate Sync Negotiation: No Maximum Sync Transfer Rate: 5 or 10

After re-booting your PC the recorder should work fine.

-- lg7 (, December 09, 2001.

Well I got similar problems. I get scsi target error when I try to make cd copies. I can't make images of my cd:s. I tried find that SCSI host adapter thing but I didn't find it. I would appreciate if someone could tell what to do.

-- Mk (, December 11, 2001.

I'm also getting 'scsi target error' with nero 5. Sometimes i can get the cd's to copy, but other times i get a fatal exception error, then the scsi target error appears.

-- Gav (, December 11, 2001.

I have the same problem on multiple machines I am running one AMD k7 1.3g with 384M Ram and Windows2000Prof, Nero 5.0 And Intel P-III 933m with 128M Ram and Windows2000AdvancedServer, Nero 5.0 Intel P-II 350m with 64M Ram and Windows98SecondEdition, Nero 5.0 I get an altogether different problem.

All Machines the only thing in common is the CD-RW Drive (Creative CDRW 8x4x32x - this is an EIDE device, but Windows always sees it as an SCSI device) and the Software used (Ahead Nero 5.0x)...

Curious - what is everyone else thinking? Is there a pattern? Is there a common thing we can determine? I am a computer technician, and can't get this thing to workl so I doubt that some regular user is going to be able to either. If we can all cross-troubleshoot and share notes, we can probably all solve each other's woes. Is there anyone else with my specific Operating System? Same error? Same device? Anyway I was able to make a few cds before it started giving me this problem. I think it may hae something to do with heat or some other lens alignment altering event.

If you think of something please feel free to email me your thoughts.


-- Dusty S. (, December 18, 2001.

Finally I see I am not the only one...

I also have a Ricoh 16X at home and a 12X at work and continually get errors on both burners. One thing I have consistently found is that I can put through 10 cheaper brand cd's (princo, datastream)and get the error everytime. But as soon as I put in a BASF or TDK, it works fine. There may be an issue with the acceptable quality of cd's but this would be a real pain in the ass having to pay twice as much for the discs because your burner cant handle the cheaper ones.

Also, at work we have about 10 other people using the Ricoh 12X's and only about 2 others are having these issues. The rest never have a problem so this would point to a hardware failure.

My burner at home is stuck between my removable HDD and my other CD rom and may be getting too hot. Sometimes I am able to burn a cd as soon as I turn on the pc but the next one will fail and the only way I can burn another one is to turn off the pc for an hour or so.

Has anyone with a Ricoh contacted the manufacturers yet? If so I would love to hear what they have to say. It's a very annoying problem...

Thanks in advance for any info anyone can supply.


-- ObSiDiaN (, December 18, 2001.

I have the same errors. System is: Acer 4*8*12, Celeron333 6BXE chipset, 196MB, *NO SCSI*. Burner has worked well for about 10 discs - now turns out coasters regularly, even at 2x. Have tried burning from HD and/or CDROM. Using good quality discs. Simulation may go OK then burn fails. Other times simulation may fail. Other times it may burn successfully. I recently installed 'Creative Infra Suite' which may have upset it. I have tried uninstalling but no fix.

Help from Ahead says; Turn off 'DMA' Turn off 'Auto Insert' Turn off 'Sync Data transfer' Turn on 'Disconnect'

I will try that tonight and see if it helps...

-- Bob (, January 07, 2002.

i started with up to then upgraded to because i couldnt get a cue to burn with i have made a few vcd's then bam! all of a sudden i uninstall and reinstall im using again and no luck... i didnt want to mess with the comment someone said about making changes to the registry untill another tried it... i am using xp and im thinking about doing a restore... also someone mentioned "sounds like a bad cd-key" IMPOSSIBLE! i have all working cd keys =D

-- sam sneed (, January 08, 2002.

ok ten coasters and 100 simulations failed later i ask for help!

End of user area of this track

Invalid write state

Could not perform EndTrack

Simulation failed at 12x

i have downgraded nero upgraded nero, uninstall reinstall many times, tried new cds and dont google search! has anyone got an easy fix for this?

im going to do system restore with xp this is bugging me so bad!

but i dont want to do a restor really so please help

i started with up to then upgraded to because i couldnt get a cue to burn with i have made a few vcd's then bam! all of a sudden i uninstall and reinstall im using again and no luck... i didnt want to mess with the comment someone said about making changes to the registry untill another tried it... i am using xp and im thinking about doing a restore... also someone mentioned "sounds like a bad cd-key" IMPOSSIBLE! i have all working cd keys =D

-- sam sneed (, January 08, 2002.

My phillips drive 1200 series will not burn. My O.S. is winXP my current version of nero is v5.5.5.1 I have tried other burning software I have check my DMA settings... primary is all DMA, secondary 0 is dma, secondary 1 is PIO... i changed it to DMA but current stays PIO I havent made any changes to my computer before this happend This happend while i was trying to burn a .mpg file in video cd mode with nero v5.5.5.1... may have been a .cue file, im not sure which I tried first. I have tried other cdr i havent tried any cd-rw... it was the first time i had used a memorex 700mb 16x new spindal. I have tried burning at lower speeds. Error did not occur during a 129mb data cd simulation at 2x, my "Recorder Buffer Level" stays steady at 98% during this simulation. And i'll be damned if when I i do the same 129mb for data cd during 8x simulation my buffer level starts at 98% then drops to 1 and then climbs back up to 98% and then it fluctualtes between 98% and 92%....lmao at word fluctuates haha. When I try burning 12x 129mb of data my buffer level starts at 96% and drops rapidly to zero and error occurs at 23% of writing to disc I have tried burning 1meg of data during a 12x test tickle mode... it finishs ok When I try to burn at 12x 108mb of data it craps out at 68% My "Recorder buffer level" climbs to 96% and steadly drops down to zero when this error occurs I have two CDR-RW writable drives. Phillips 12x is the master drive...the one im having problem with, the other is memorex 2x that works ok... This is error message I receive while writing a data cd. The error reads out exactly like this:

Caching of files started Caching of files completed Simulation started at 12x (1800 KB/s) PCRW 1208 Invalid block address PCRW1208 Could not perform EndTrack Simulation failed at 12x (1800 KB/s)

While burning an Audio cd error reads out almost the same:

Caching of files started Caching of files completed Simulation started at 12x (1800 KB/s) PCRW 1208 Invalid block address Simulation failed at 12x (1800 KB/s)

Error occurs after 5% of writing to the disc has been done, instead of 68% because the audio cd is 702mb instead of the 108mb test run on the data cd.

While writing a Video1 (Mode2/XA) with nero Same error as the audio cd. The video size was 582mb and the error occurs after 6% of writing to the disc has been done.

thats all for now i know im still forgetting something

-- sam sneed (, January 10, 2002.

Mines working fine again now that I have changed the CD settings as below. (As per Aheads instructions). Turn off 'DMA' Turn off 'Auto Insert' Turn off 'Sync Data transfer' Turn on 'Disconnect' Good Luck, Bob

-- Bob (, January 10, 2002.

Hi ! I have the same problems like you around here.

My Coaster was an Ricoh 16x10x32 call 7163a !!!

I have burned some VCD and normal CD`s ! Then it happened.

SCSI Target error !!!!!!

I have tried newer and older Version`s of NERO ! But nothing happened.Then I tried to reinstall XP. Same problem.

But then I tried CD-Mate and guys , everything works fine with this great program.

Now I burned every CD at full speed.

-- JayCee73 (, January 11, 2002.

The problem is the ASPI driver. To get the newest ASPI driver got to and search for "download aspi driver". Look at the results to find to download the "Aspi32.exe". At the setup ignore the message it is only for win98 an NT, it's for all operating systems (me it was Win2k). After a reboot it should be properly work, if not get the newest ATA driver and install it.

-- Detlef Michler (, January 18, 2002.

hey everyone...I had the SCSI Target Error problem and this is how I fixed it:

1) Followed ahead's troubleshooting stuff (disabled autorun, dma etc)

2) Installed the lastest winaspi drivers

3) Installed the latest ata drivers

4) Rebooted

now it seems like it's burning like it used to :) good luck

-- Namus (, January 25, 2002.

SCSI Target error is killing me! I have been through the whole thing, no help from Ahead, did all the suggestions, installed the WINASPI drivers etc etc. I am using the 440bx chipset with Windows 98, upgraded to the latest Nero and am still having no luck, 12x 8x using the Lite-on 12101B with latest firmware, Memorex CD-Rs. Any suggestions, should i trash Nero?

-- Steve Dunhaver (, January 29, 2002.

I had the same problem. I found that on the ahead site : For me it was the second case...

SCSI Target Error If the error message SCSI Target Error appears as the first error in the log file:

If a SCSI CD Writer is being used, then please check if the settings in the BIOS of the SCSI hostadapter are set correctly. On this, see recommended hardware settings.

This error sometimes occurs if, when burning over image, the CD-R had already been inserted before Nero asks for it. Please do not insert the CD until Nero asks for the CD-R.

If you are using one of the following CD Writer : Compro CW-7502, Matsushita CW-7502, Panasonic CW-7502, Plasmon CDR480

Please check if you have got the newest Firmware .

Please check if the error message disappears if the switch off the automatic is deactivated. If you are using an Adaptec SCSI Hostadapter in the system: Please download and install the newest WinASPI drivers from the Adaptec WebSite. Please ask TechSupport ( for Qoff3MB.

-- Laurent (, February 01, 2002.

Got the same problem, and I have tried EVERYTHING! Installed the latest ASPI32, according to the MS site, my ATA drivers are the latest, changed operating systems, moved the CD writer to a different machine, changed CD burning software, changed CD brands, tried all DMA and non-DMA settings, turned all CD options on and off, and followed all the advice on the Nero groups. Although I have a SCSI port, the CD writer is NOT on the SCSI port. However, the software identifies it as being connected to the SCSI port, even before it tries to write.

Since everyone has a different solution, it sounds like they solved the problem accidently while trying other stuff. Does anyone know what actually causes this?

-- M.F. (, February 17, 2002.

First off, SCSI Target error on IDE CDRWs!!!! Give me a break. yeah I know that the drives are SCSI on the inside and IDE on the outside. I run Nero5 on 3 Pentium III machines,with win98 and everything's groovy. I also build machines for a living and I recently sold a Pentium 4 with a Lite On burner and Nero 5. SCSI TARGET ERRORS...... but here's the kicker....only sometimes. So go ahead and set all the settings you want. (The Intel 850 chipset drivers don't allow you to change the UDMA on the CDRW). Anywhoo I put Roxio on and..... Voila, everything's fine again. Lesson learned.? Even though I don't care for Roxios politics I've never had a problem burnig with Roxio. By the sheer number of posts I'd say that Nero has issues on fundamental levels. The simple fact that this particular problem is an intermitent makes me think bad thoughts. I personally will keep using Nero on the machines that will work, However in my proffesional capacity I don't think I can promote Nero's product.

-- S.B.S. (, February 22, 2002.

I've read almost all the responses here and it looks like most people are having the same problem that I had. My problem was this: With Nero, NTI CD-Maker Pro, native Win XP writing, or any other burner software, I was unable to write to any disc at speeds above 8X. If I did, I'd end up getting combinations of errors everyone here is getting. For example, this is what was happening at speeds above 8X with Nero: The recorder buffer level would initially fill up to 98% like it should, then recording would begin and the buffer level would slowly drop to zero and the recording would fail. For some reason, the recorder buffer would not be replenished and the recording would fail once the buffer was empty. Strangely, at speeds of 8X or lower, it would work fine and the buffer would stay at around 98%. After some diagnostics (and thinking), I realized that this problem started when I swapped out an old Adaptec 2940U adapter with a newer 2940U2 adapter to utilize some Ultra2 hard drives I had. For those not familiar with the Adaptec family of SCSI cards, the 2940U adapter was SE only while the 2940U2 was Ultra2 and SE (separate connections for each). Next, I pulled out the 2940U2 card and put in a brand new Adaptec 29160N Ultra160 controller, but unfortunately still had the same problem. I tried everything, like tweaking every possible setting on the controller and using different drivers. Finally I put the old 2940U adapter back in the computer, right next to the new 29160N and plugged all my SE devices back into it (CD-RW drives and tape drive). Now everything is fine again and I can record at top speed without any errors. Seems kind of a waste having two controllers in there, but in my experience, the newer Adaptec cards seem to have problems with CD-RW drives. I can only speculate as to what the problem might be. Perhaps the system has an issue with having the Ultra and SE controllers on the same card and same interrupt?

-- Nyte Byte (, March 03, 2002.

Follow-up to my original post: the only thing in common with all the failures was the drive itself. I finally broke down and bought a new one, and the problem vanished, with no fiddling whatsoever. I can now burn at 24X. What this suggests is that this might be the last-gasp error your CD or associated hardware gives when it's finally bought the farm. The intermittancy of the problem for most people supports this...there's nothing quite so magical as a hardware bug. My guess is that diagnostics gets confused by a mechanical failure (dirty lens, jammed motor, poor tracking) and gives you this. So if you are getting this message, consider that your drive may be worn out or defective, and may need replacement.

-- M.F. (, March 05, 2002.

Try end-tasking InCD and see if it works now!!

-- Kahakberacun (, March 18, 2002.

Hi Do yourself a favour and dump Nero.I had the same problems then switched to NTI CD Maker Pro.Burner has never run better or faster Hope this helps Cheers

-- N W (, March 19, 2002.

forget about all the answers above: the ONE AND ONLY SOLUTION is that NERO Burning ROM does not like the presence of OTHER installed burning programs on your harddisk.

Uninstall other programs with burning facilities and your Nero is OK again, no more EndTrack or other problems. In my experience, most problems with Nero (I once had problems with RESET BUS, this was due to conflict with CloneCD) result from conflicts with other similar software.

-- PC Prophet (, April 02, 2002.


PC-Prophet is right. My Nero installation was fine, I never had problems until I installed CDRWIN 5.0. CDRWIN 3.8 didn't trouble Nero. But CDRWIN 5.0 seems to be from a totally different firm (not Goldenhawk). Nero and CDRWIN 3.8 are the only applications that would never give me any trouble. I tried WinOnCD (shipping with the CD-R Burner) and Easy CD Creator 4.0 and 5.0 (both bought legally at German retail shops, both being far more expensive than Nero.) After dumping them I feel a lot better and have more time ... :-)


-- A. Bodemer (, April 09, 2002.

I have the same scsi problem, but my friend can burn the cd successfully with my cdrw recoder. So I thought it will not be the reason of my hardware. maybe I'd better choose another cdr software. :-<

-- Jerry (, April 22, 2002.

well, i see that i'm not alone with this problem... So all i can do is to write down this: I'm using WInXP, Nero, HP CD_Writer 8200a, I have NO SCSI devices. I've being using this for a while and all of the sudden just started to send me that error...

I'm tring to fix it, so if I find something, I'll let you know...

-- Whycyber (, April 29, 2002.

In addition to my previous answer to all your "endtrack" problems: there are in fact two possible causes

1. either your Nero is troubled by interference with other burning programs (especially CloneCD, uninstall them all)

2. make sure you have sufficient hard disk space left for Nero to do the operation (if you write a CD of 650 MB, make sure you have left at least 650 Mb of free disk space)

-- PC Prophet (, May 02, 2002.

Hmm... there seem to be some solutions here.. will try them and let you know ;)

I'm having the same problems... OS: Win2K SP1 Plextor 12/10/32 on the secondary IDE channel as slave in UDMA mode. Old Adaptec 2940 AU card on the system Adaptec ASPI drivers v.4.70. Nero Burning Rom v.5.5.8

My old burner started all of the sudden burning coasters (a Sony 8x burner), so I simply concluded a hardware error. I then borrowed this Plextor burner from a m8, and the first burn @ 12x went just fine. But then I got these "EndTrack" errors too, after various %'s of completion...

I've got CloneCD & CDRWin installed too.... gonnna try to:

1. Check my IDE mode settings for all IDE connected devices.

2. Upgrade the ASPI drivers (Adaptec has finally released the ASPI drivers on their webpage).

3. Do those Ahead recommended Turn off 'DMA' Turn off 'Auto Insert' Turn off 'Sync Data transfer' Turn on 'Disconnect'.

4. Uninstall the other burning applications.

5. Try another burning software.

Will let ya know ;)

-- Masken (, May 03, 2002.

I have an IDE drive and yet suddenly this evening I found the same problems as everyone else after burning about 4%

ie Invalid Writestate, Couldn't perform end track, Burn process failed

However, I found the answer to my causes quite easily. Whilst going through the process to burn a disk, I was being warned about files with more than 255 characters and more than 8 levels in a folder tree and I was just clicking continue or OK. Thus I had the error messages above. I found that I could remove the problems in one of two ways.

Firstly, change the file and folder system so they complied with the 255 characters and 8 levels of folders.

Secondly, put a tick in both boxes on the ISO page to relax both of the restrictions.

I hope this helps, good luck,


-- alan mac (, May 09, 2002.

hey--i had a similar problem with my acer20x10x40 and nero--scsi target error, buffer underrun, couldn't perform end track etc. i've wasted about 20+ blanks lately (after many successful simulations too!) and on a message board i saw something i thought i oughta try--here goes--

firstly i uninstalled nero from control panel--add/remove, then did a system search for all files containing 'ahead' and 'nero' and deleted them (i found 4 previous versions of nero in a folder that i had 'uninstalled'! maybe this was part of the issue). i then went into registry editor start--run--regedit and found, again, all things nero and ahead and carefully deleted them. i also looked for other burning plug-ins like easycd and deleted them as i know nero has issues with them. (when you edit the system registry though do be careful what you delete!).

after removing all traces of ahead/nero i restarted then reinstalled my version, restarted and updated it to the version from their site and when i used nero next--i burned at 8x to try and eliminate buffer underrun and so it worked successfully! next time i'll try at 20x!

i hope this helps anyone with issues cos i know how frustrating it can be!

-- dave (, May 20, 2002.

hi too everybody i have the same problems with nero after some weeks when i start to burn there comes SCSI Target Error can please somebody help me and write here or on my email adress how i can repeare this problem

-- T-D (, May 24, 2002.

Hi guys!

Same problem here :( Everything was working alright on Win2K, but since I upgraded to WinXP I've been having problems with my Archos MiniCDRW (USB).

I am not sure if this is just a coincidence, or if it's an incompatibility with XP.

I got all the latest drivers off Archos, re-installed Nero, tried EasyCD Creator & NTI CD Maker... nothing.

I think I will be taking my drive to Dixons for a checkup.

-- Giorgio (, May 26, 2002.


My story should sound family to many of you. Had a Win98SE system with a IDE Sony 8x burner, working great with the latest Nero. Installed XP Pro (kept 98SE on a separate drive), and was doing fine until a few weeks ago. Kept getting "Communication Error" "Write state invalid" on SIMULATIONS AND BURNS, for AUDIO AND DATA - and this was with the same brand CD-R's I had been using before. Booting into 98SE, the drive worked flawlessly.

I have spent a good 2 weeks trying to find a solution. My theories involved trying the built-in software in XP (some success, some failures), CDRWin (failure), installing the Adaptec 1.7 ASPI, changing registry settings, etc. Uninstalling, reinstalling, uninstalling, clearing registry, reinstalling.... etc...

Reading about folks having SCSI issues, and noticing that all of my hard drives and CD/DVD drives are listed as SCSI devices, I wondered about my IDE controller. I added a ATA/66 IDE controller for my 120GB 7200rpm drive, and had the burner on it's own controller off the main motherboard.

So I went into the Device Manager, and under Advanced Property settings for my Primary IDE controller, the burner was set to DMA 2. While the burner might be DMA 2 compatible, I knew that my 5x DVD-ROM drive was not, so I changed it to "PIO" instead. My next simulations and burns worked flawlessly. The computer seems to be less responsive during a MP3->Audio CD burn, which may be due to the lack of DMA transfer, but it works.

I hope this is of help to any of you out there who now have a stack of coasters.

-- Evan (, June 05, 2002.

I had the following problem:

While Nero was burning the CD, the recorder-buffer runs empty until 6% and was then refilled from nero. It looked like a cyclic progress bar. I think I was able to burn CD's, because the drive used burn-proof. Otherwise I would have get a buffer-underrun. (my gramma :-)))

My specific hardware:

Adaptec 19160 Teac CD-W512SK

The Solution:

I installed the latest driver for the adaptec-host from the adaptec-homepage (d4.2 - v4.10.4002).

That was all :)

Now the recorder-buffer is always at eg. 98%.

I hope, I can help someone.


-- Stuffel, Mirko Alexander (, June 12, 2002.

I was updating my nephews computer (733mhz, 128Mb, UltraATA, WinME, *Sony CRX140E CDR-W ...etc)and upon testing I kept running into Burn Errors... "SCSI Target Error" among many others. I tried every suggestion made ie... Drivers, Firmware, DMA, Auto Insert, Turn-Off UDMA etc... Then... I FOUND A SOLUTION FOR MY PROBLEM!!!! This Sony CDR-W (CRX 140E Firmware "S")can not recognize "High Speed" Discs... viola... Look at the disc and if it does not read "HIGH SPEED" (usually next to the Compact Disc Logo) give it a try. Note: I guess the 8 write speed is useless with CDR-W's because to my knowledge (limited), Non-High Speed discs are limited to a speed of x1. x2, x4. But what the Hey... it works!!!

-- MarkED (, June 24, 2002.


if your burner is ide, you may ask - "what scsi?!?" and you have a strong case here.

nero is installed with an ASPI driver which is the problem. go to the NERO directory, and REMOVE the file with "winaspi" or "aspi" in its name. just let windows deal with drivers - the NERO one should be disabled. windows native drivers work just fine, for that matter.

i've read this long ago in another forum, and never encountered the problem again.

hope it works for everyone here, good luck.

-- yaneev t (, June 28, 2002.


ive got a yamaha 16*10*40. the things i am able to do on my computer while burning at x16 speed: 1.render on after effect 2.render on 3 parallel 3dsMax 3.listen to mp3s the web so i don't get bored ALL AT THE SAME TIME.

so i'm quite happy with NERO, besides it's being such a friendly app.

all yours, y

-- yaneev t (, June 28, 2002.

Came across Nero 5.0 w/purchase of A-open 1232 cdrw. Upgraded to 5.5 thur net(Buggy.. but worked). After up grade of m/b & cpu Nero 5.5 net up grade decided not to copy cd's. Giving me error messages of "invalid write state" & "could not perform end of disk at once". As usuall Nero does not answer e-mail queires nor can user groups come up with a solid answer to this very selective program on how it wants to perform. I only keep it for the jewel case cover design. My solution is to uninstalled Nero, leaving cover designer w/ message time was up on demo,(this does not work for newest upgrade, only 5.5) reinstalled Nero 5.0 from disk. Cover designer works and so does cd copy, overall bugginess is lessened. Don't ask why,I don't know. Several times I have had to do this when I forget "kiss" (Keep It Simple Stupid) or need the wave editor. Hope this helps.

-- Bill Seletos (, July 14, 2002.

Earler Post: Wrong answer to Combatpk. My problem is w/audio cd's not vcd's. Sorry for the confusion. Bill

-- Bill Seletos (, July 14, 2002.

why the fuck is everyone posting saying that they have the same problem and not helping?

-- blocky (, July 18, 2002.

I was going through this thread and trying many of the suggestions but nothing worked. I am running Windows XP Pro with Nero and a Sumsung 16X10X32 CDRW. I have had most of the exact same issues that everyone's complaining about on this thread. I finally found a solution that is EASY but it'll cost you a tiny bit of cash...Get Tweak XP! There's a very simple interface for those who don't want to hack through loads of registry entries or try to find out where they can turn off certain Windows functions.

I just checked the box where it said "turn of Windows CD burning" and voila, now I am burning away with Nero and no problems. What an f-ing relief!

-- Fred (, July 18, 2002.

thanks Kahakberacun After messing around getting scsi target errors in Nero for the last 2 weeks (after installing a new burner), I end-tasked incd & no more errors! I upgraded to incd ver. 3.31.0, and it seems to have fixed my problem.

-- Mark (, July 20, 2002.

Listen I had 10 invalid block address errors in a row.....I downloaded Nero {Nero Express} add chose combo Audio/Data and burned fine......Also if your loading saved projects I suggest start from scratch again, that could also be a problem.

Best Of LucK!

-- Dre (, July 24, 2002.

Same problem here. Installed the ASPI for Win2k files that i have used on another computer and it have always worked. But not on the one i´m fixing now. Tried DMA = off, tried audoplay = 0, tried renaming the winaspi-file in the Nero luck.

-- Patrik (, July 25, 2002.

I ran into the 'invalid writestate' with Nero on a fresh install of XP. I tried most of the suggestions on this thread and ended up with a pile of coasters. I finally got Nero to work normally by downloading & installing a demo version of CDRWIN 3.9a. CDRWIN burned okay at the demo speed of 1x, so I tried Nero and it burned troublefree at the CDRW drive's rated speed of 8X. CDRWIN installs the ASPI drivers correctly, and I assume that is what resolved the 'invalid writestate' condition. Good luck.

-- Art Vandalay (, July 29, 2002.

I just got rid of SCSI target error. It seems that Windows Media Player 7.0 adds Adaptec burning capablities which will not get along with Nero. I deleted just the Adaptec portion with a selective removal and Nero works fine. Hope it helps somebody.

-- Ray (, July 30, 2002.

I have slowed the writing speed down and it has fixed the problem :)

-- Eddie (, August 01, 2002.

I had a SCSI target error using Nero 5.0, using a plextor 8/4/32 and "High Speed" 10X CD-RW's and I was trying to make a SVCD. I fixed the problem when I realized that Plextor 8/4/32 drives cannot write to high-speed 10X cd-rw's:

When I switched to "normal speed" 4X cd rw's it worked perfectly.

-- jimmy autler (, August 04, 2002.

I had the same problem as everyone else in this site, i had tried everything to fix my LG writer, until this nite i found my answer. If anyone wishes to try this by all means give it a go.. Rename the following .vxd files that come standard with Win 95 and 98 and then reboot the system:

atapchng.vxd - rename to atapchng.vx_ necatapi.vxd - rename to necatapi.vx_ torisan3.vxd - rename to torisan3.vx_ scsi1hlp.vxd - rename to scsi1hlp.vx_ the reason why you may need to do this is that Windows and Nero or ECDC conflict with these files and therefore fail to do a burn. So rename these files and you should be right. Hope this can help someone!!!

-- Master Yoda (, August 12, 2002.

Well, I used to have a lot of coasters, but now that I've stuck to these 'guidelines' I haven't wasted any CDs (yet!)

1) Write CDs as soon as you boot up. Don't give the Drive time to heat up. 2) It's okay to write on cheap quality medium (I use princo/frontech) but don't expect to burn more that 3-4 cds one after the other. 3) Don't do anything else while burning. Especially don't play music. Also, vibrations from music sometimes mess up burning (or so they say)

-- Pranab Salian (, September 13, 2002.

And yes . .. . .. .

Whatever your CD or CDRW says, stick to burning only at 8x. :^/

-- Pranab Salian (, September 13, 2002.

Hi people. I have an other problem here with my nero latest version .... when i use nero express i cant add files to the compilation. It says "out of memory" . But I dont have such a problem when i use nero burning. I have windows xp.

Any suggestions??? :(

Thanks in advance

-- Kyrillos (, November 04, 2002.

XP Hell. From the looks of it we're all experiencing it. I have a Dell P4 that came with DVD_Rom and CD-RW (LG 8080B). It was working for a while and then coaster city. I've tried most of the suggestions already listed here - from other forums on the net and friends - all to no avail. I'm starting to think its hardware related as well. If its so damn random it must be compatibility or hardware failure. If anyone had the time, a synopsis of all the suggested fixes in one post would be great. Good luck to all -

-- JK (, November 06, 2002.

I have Win 98SE and LG 12x writer. I also have this Buffer underrun -> invalid write state problem. I had win XP pro and everything worked perfectly. I have nero and NO OTHER write programs. I have tried everything (ASPI, renaming files, disabling auto insert notification etc.) Well, now it works fine, because I dropped write speed from 12x to 8x. You all should try this.

The reason I removed XP is that it was playing Diablo 2 and then suddenly my machine rebooted(???) After that, XP never started again. This happened 2 times with different programs (I´m sure I don´t have viruses)

Yes, I know. This went off-topic. Just wanted to say this to everyone who is about to install XP.

-- Pekka Mäkinen (, November 07, 2002.

I had SCSI target error and I tried everything is explained in this FAQ, and nothing, so finally one day I saw one friend having the same problem with one CD-RW I used, and he never had this problem, saw I thought about keeping trying it with another CDs and finally I get the solution, at least in my case. I stop using the High speed CD and I use Multi-Speed or normal CDs and it works. My CD recorder is 8x4x32 Creative.

I hope that it helps.

Capitan Spock

-- The Capitan Spock (, November 08, 2002.

yea im also having the same problems with the invalid block state, invalid write state and could not perform end track. I was trying to burn an avi file and i selected auto shutdown when complete. I think this is the problem because my burns have been flawless to this point. I cant resume the file, but is there still hope for my cd or will it serve best as a coaster?

-- Will (, December 01, 2002.

Check out this address:

It may solve most of your problems...

-- Anderson Monteiro (, December 21, 2002.

Got the same problem of SCSI target ERROR every time I was trying to use Nero. I move the file WNASPI32.DLL from the Nero directory into the trash. Everything is OK now my HP 8X4X32X doesn't cocksuck anymore.

-- Danny Belanger (, December 24, 2002.

i had the same problem. i now have a working cd burner. here's what i did:

first, i got new aspi drivers. i replaced all instances of my old aspi32.dll with a new one, and replaced all instances of wnaspi32.dll with a new one. reboot, test, still a fail. there was something else wrong.

i read a post a while back in this thread about cdrwin 5.x, and realized that i had it installed. upon an instpection of "My Computer," i noticed that since my install of cdrwin that i had a virtual scsi cd drive showing up under my drives listing. i removed cdrwin.

but, before i restarted, i also set the ide controller my burner is on to pio, and i removed roxio5. upon reboot, the burner worked.

and here's my take on the thing: i dont think switching to pio instead of dma made a difference, since i'd run it with dma before a reformat. i've also run nero successfully before while roxio was installed. therefore, i'm inclined to think that cdrwin, and its virtual scsi device, was the cause of the problem.

some of you may be getting this error w/out having cdrwin installed on your system. look at other programs that may be creating virtual devices, and try to disable them. hope i can help someone... good luck with the burns.

-- erik finkelnburg (, December 26, 2002.

Hi! After one month using my brand new PC, I got the same problem as all of you (at least the sinthoms). I tried everyting posted, installed lots of cd burners, and always the same: SCSI target error. I tried my CD-writer with my old laptop, and it worked as usual... So finally, I connected the laptop to the PC using a LAN connection, transferred all personal data, and reinstalled XP from scratch. As expected, everything is working again. My recomendation is that, if you have a way to get the data (network, other working cd-writer, parallel connection...), do it, and fully reinstall XP, you will save a lot lot of time!

Now, I am going to install everything step by step, testing the cd- writer. If I found wich application causes the problem, I will post it.

Good luck.

-- Javier (, December 31, 2002.

The last answer to the problem is correct, except you don't have to change any setting or get new drivers, Almost all Windows O.S. have Roxio bundled with it. Just get rid of ANYTHING that says Roxio or cdrwin on you computer and reinstall Nero. And for the love of god, You people with the Demo version, go to Kazza and get a Damn serial and you will stop having most problems. Please E-Mail me and let me know if you have any problem, we cam IM each other and I will Help.

-- TTG (, December 31, 2002.

By the way. If any of you have any other cd burning software on your computer get rid of it(might help). Not to be a salesman, but Nero is the BEST cd burning, encoding, decoding, and copy software you can get. JUST USE IT CORRECTLY AND IT WILL TREAT YOU JUST FINE.

-- TTG (, December 31, 2002.

O.K. I have an anwer if you have problems with a USB CDR-W. I used to get that "Invalid Write State" "Could Not Perform End Track" The problem was too many things connected to my USB root HUB. Now I am no computer expert, but removing all devices connected to the same hub or root hub my CDR-W was connected to, made my CDRW Work right. I didnt need to reinstall everyting.

-- Burner (, January 06, 2003.

initially i had win98 with cendyne cdrw and nero software. no problems. then converted to winxp. "scsi target error" appears on every burn. SOLUTION to my problem:

1. click on RUN 2. type REGEDIT 3. click EDIT | FIND on registry window 4. find any NERO, AHEAD, ADAPTEC, ROXIO files and deleted them 5. Reinstalled NERO 6. no more problems.... :)

-- eu-ric (, January 15, 2003.

I'm having the same problem as well--I've been using the program for about a year, all of a sudden I get SCSI target errors no matter what I'm burning. I downloaded the latest version and still get the same errors. I'm using an HP external USB. Any help would be greatly appreciated

-- Winston (, January 30, 2003.

ok gonna answer ur prayers!!!!!....about the end track problem with Nero...YES!...heres the answer...i know its gonna sound wierd and stupid..but i had the same problem...and wasted about 12 cds trying to burn and avi movie file...but i finally got it.. all i did was rename the .avi file to a .mpg..and then tried burning worked...perfectly...try it! worked for me!

-- Strane (, February 07, 2003.

I was having this problem for months, and wasting literally 100s of CDs (I burn them for a living). Despite trying all the suggestions on this site, nothing would work, and usually about 1 in 6 would fail - totally unacceptable I think you'll agree. I managed to keep the failure ratio as low as possible by not having any other programs opened at the same time. One particular program, windows media player, would always guarantee a scsi target error whenever I started it during the burn process.

But hey, I managed to fix the problem - you know how? By upgrading to a broadband internet connection!!! Don't ask me how this has worked but it has - I can have as many programs open and running at the same time as I want, the scsi target error is banished to history for me. Totally bizarre really - but if you have run out of solutions, maybe you should consider an upgrade to broadband, it worked for me!

-- Tristan (, March 17, 2003.

Got me a plextor 48/24/84 Everything worked fine , even great till yesterday got the same errors as you guys , Now is there a working solution? thx m8

-- Mvds (, March 17, 2003.

I recently purchased a Benq 2410MR Mini CD-RW(external). I havent been able to burn a single cd since.Every time I begin a burn,it burns for abt 50-90% and then says "SCSI Target Error,Invalid WriteState,Could not perform End of track". This happens everytime I tried to burn a cd either way image/cd-copy.I use Nero Ahead to write the cds.Pls tell me if its a problem with my system or Nero S/w.If I switch to another cd writing s/w will the problem go off? When I tried the same cd-writer and Nero s/w on another computer it works perfectly,which leads me to think its probably got to go something with my system. I tried on both WIn98 and 2000 but the same error msg. Pls help!!!

-- CodeWanted (, March 18, 2003.

i have a similar problem - i upgraded my old pii - 333 to a p4 -2.4 by changing the m/b and cpu, i am also continuing to run win 98se... since the upgrade, nero hangs at around 3% READ... it doesn't even get to the writing... i noticed that the buffer gets to around 55%, then jumps to 99%, and then goes to zero, then CRASH!... i have tried reinstallng nero, and messing wiht the dma, etc settings to no avail.. i have used audiograbber etc to rip tracks, so i know that there isn't a problem there, i thought a faster cpu would makes things better, not worse... any ideas?

-- Lucas Perez (, March 19, 2003.

Ok peeps, hold on to your pocket protectors cuz I'm about to enlighten you to something you already know(If you've read this complete thread that is). Alot of us are having 'issues' related to the 'SCSI Target error' and 'Invalid Writestate' and 'Could not preform Endtrack' and ........... you get the idea. Anyway the problem is that there is no one solution, SURPRISE! Of course I have had the problem myself and believe me it was an elusive fix if nothing else. I beleive all the suggestions posted here are valid and if put into sequence I beleive everyone can fix the problem eventually. Beings the problem can occur due to a number of factors there needs to be a order in which to do your diagnosing in, and you got it I'm going to force my opinion on you by breaking the problem down. Here we go ......

1. Due to the large amount of juice ALL burners require to do their jobs correctly you need to ensure that the power supply to the machine is constant in other words no surges (even smell ones) and that nothing is drawing power from the burner such as in my case. Let me explain, I had a 'slot' fan running under my video card to keep the processor cool. The fan needed to be powered by an existing power connector (the ones you plug into your hard drives and cd drives), so to power the fan I connected it inline on the burner connector. I had no problems up until recently when I started getting the errors, I noticed the errors started happening when the fan started to make noises like the motor was going bad. Well come to find out the fan motor went bad and was drawing more power than usual to turn the fan thus causing the burner to fail while trying to write to a disc, not enough juice. I disconnected it and eveything was peachy :) Of course not everyone is going to have this problem so lets move on to the next step. Test it!

2. Once you've determined the burner is getting the required juice I would recommend trying to find the appropriate firmware updates for your burner. Not only is this a good suggestion but you should do it anyway, thats why they're out there. Remember to read up on the firmware installs though, not all firmware will fix what needs to be fixed and can sometimes permanently destroy a device, believe me I know. Test it!

3. Firmware up to date we move on to the burning software. You only need one burning application to do the job, determine what you're job requirements are and use the appropriate application. DO NOT - install multiple burning applications you're just asking for trouble and of course you'll be on your own to figure it out. If however you do use multiple burning applications, for the love of god search all drives for 'aspi' and rename the 'WNASPI32.DLL' and 'WINASPI.DLL' files found in the directories of the burning software only, do not touch the files in your windows/systems32 directory. Simply rename them by replacing the last letter in the extension with an underscore and be done with it. Trust me one copy is all you need to make the SCSI and IDE world connect and if it's in the windows system32 directory all your other applications will find it or Windows will show them where to find it. Reboot and Test it!

4. If you still arent having any luck I would recommend downloading the latest ASPI install executable from adaptec's site. Read the readme on how to install these files to make your life easier, dont just start clicking executables, there are files for multiple OS's in the archive. Once you've successfully installed the files, rebooted and verified they are up to got it Test it!

5. The first four steps in my opinion are the crucial ones and of course they wont work for everyone. As you know if you read this thread there are a multitude of seemingly miniscule tweaks and fixes that will automagically make the burner work. If you are still having problems read through the rest of the threads for other ideas and suggestions, they are all worth looking into. And if all else fails you might need a little luck, some troubleshooting skills and a little time to really dig in and figure it out.

I appologize for the length of this post but I cant stand the thought of someone else having to read the fragillion posts in this thread to get nowhere, I hope I've summed up the major things to look at and if I've helped even one of us through this post my work here is done. Also, as I've mentioned these are not the be all end all solutions just suggestions to help make a long journey shorter. Good Luck ;)

-- Jamie Steffen (, March 20, 2003.

Can someone specifically tell me if this SCSI Target Error is related to Nero only.As I have seen from several sites,most ppl claiming this problem seem to be using Nero.If it is S/W related,maybe switching to another s/w can help me. With respect to Jamie's solution, 1.Theres no prob with my fan, 2.I guess the firmwares I have are good enough since the writer works perfectly on 2 of my friends comp. 3.I do not have any other writing s/w 4.This prob was on both Win98 and Win2000Pro on my system only :( What should I do?Its so bad that my brand new CD-RW seems on work on everyone's system except mine!!

-- CodeWanted (, March 21, 2003.

just to clarify... how many of you are using Gigabyte P4 Titan m/bs? could the problem we're having be ralted to this, as when i did the upgrade, all i changed was m/b, cpu, and memory...

-- Lucas Perez (, March 21, 2003.

Here is how I fixed my SCSI target problem with Nero on XP. Mine was a fresh install from an xp cd so I know I had no other cd burning software other then Windows media player and the stuff built into xp.I tried all the stuff on the nero site - turned of xp burning - autoplay - turned off DMa - none of that stuff worked. I turned it all back on and put it back the way it was to start with. The prolbem is the version of WNASPI32.dll in the nero directory. You cannot delete it in XP or nero will not work. The new version with the latest nero update is the problem. I replaced it after running the update with the one from my nero cd. The timestamp on the good file is 5-21-2001 6:35am. I am back to burning cd's in 2 minutes. I did not change any other files or reg settings.

I will send you this file if you need it. It fixed all my problems and like I said. I have the windows cd burning turned back on so I can drag and drop and autoplay is on and DMA and it all works fine. It is just the one file you need to replace.

-- VF (, March 23, 2003.

I also had these similar "burning issues" using Nero and a Sony DRU-500 AX, firmware 2e. I had to reinstall Win2K for other reasons, but after doing so, I could not burn a full DVD. I kept getting a generic write error message and then the dreaded "Invalid block address" message. I could not even reformat DVD+RWs. My Sony is connected to my motherboard via a SIIG UltraATA 100 PCI controller card and I have the latest ASPI32 drivers (4.71a2). My problem was fixed by enabling DMA using the device manager ( Prior to enabling DMA, I would be using 80% of my CPU to burn DVDs. Now it's back down to less than 10%. Nice.

-- Kenneth Papp (, April 04, 2003.

I removed the aspi with Force aspi and reinstalled the newest adaptec aspi drivers. I have done this before and didn't work. This time I added a twist, instead of installing of Nero, I installed a previous version and presto, it works (fingers crossed and 3 successful dvd later). Not sure, but maybe a flaw in the new version. I will give it a try but not sure how long it will last. It seems to definetly be a software issue.

-- Matt H (, April 10, 2003.

I think this thread is great - lots of smart people trying to wrestle with a difficult technical problem, for a couple of years.

I've got the same problem - after a year of no problems, my Nero - Plextor 4012 - Advansys SCSI - Windows2000pro is going: "write error" -> "Invalid write state" -> "Cannot Perform EndTrack". CD's gone. I replaced the wnaspi32.dll in the Nero directory, which was 128k, with the current file at the Nero ftp site (156k). Didn't help. Didn't do the BIOS tweaks yet - I'll report the outcome once I do them.

What's different now in the way I use the system, is that there is a much higher communication load on that PC. It has always served as an ADSL (ICS) gateway, but recently I've been downloading large files, using many TCP/IP connections.

(By the way, this rings a bell about a previous post in this thread, of someone who said that once he moved to a broadband Internet connection, his problems got solved). I don't think Nero should produce errors if your Internet link is throttling, but it seems that when the system is loaded, that's the time when bugs and non spic-and- span system settings start having their effect.

-- Jack Arenberg (, April 13, 2003.

I don't have an answer, but I wish someone had a correct answer. I've tried solutions to this problem over and over again. I've tried uninstalling Nero, and going back to previous version(s), I've tried upgrading to the most recent version. I've tried to download the latest firmware. I've tried to switch to Easy CD Creator. I've tried to go back to Nero when Easy CD Creator wasn't the answer. I've tried EVERYTHING listed on the Nero website, which is just a bunch of crap. I've tried changing CDR brands (several times), even though I had used the same brand with no problems whatsoever, until one day my CD burning days went south. I just can't imagine why my CD burner would work just fine with Nero one day, and the next day I get the same errors as everyone else that has this complaint. I've had Power Calibration errors, and the ever unpopular "Could not perform EndTrack" error. I have absolutely had it, and you would think with so many people having the same error, SOMEBODY out there has a fix for the problem. I have found that I can get a much better success rate at burning @ 8X or even at 4X, but I dare not venture into the world of 12X or higher, even though I was burning at 32X without a problem for quite some time. I would like to think that I'm very proficient in problem solving, but I can't take this problem anymore. I'm about to go off the deep end. Now that I'm through venting...SOMEBODY PLEASE FIND THE SOLUTION!!!!

-- shane loudon (, April 23, 2003.

Well aint this great... a thread almost 3 years long, and still no definative answer.

Well what are we to do? I first encountered this problem with roxio about 4 years ago. Since then ive gotten a new burner and gotton rid off roxio (I hated it). I was succesfully burning every cd at 48x with now probs', but all of a sudden im gettin scsi errors again. What SCSI??!!! Well 1st im gunna try and update everything but if that doesnt work im gunna have to find new s/w...or somethin', i dunno. Its very weird and very annoying!...

-- snupyfie (, April 26, 2003.

Sorry--another noob question:

I am using Neron on Win2k with a BenQ CDRW and get so many errors I am ready to trash my CDRW. We can put a man on the moon but can't do squat with burner technology.

Why is it that I am sometimes able to burn CDs but not data CDs?

AND--when you say download the latest ATA driver--what is an ATA driver? Is there one for each specific CDRW or is it a general update everyone can use? Where can I find it?

Cheers, Gene

-- gene frizzell (, May 06, 2003.

If u use SCSI technology (very few people do) then update ur SCSI drivers and ur ATA drivers and ur ASPI and the problem should be fixed.

If you gettin this problem with IDE cdRW then undateing any of the above it completely pointless and u dont even use it in ur hardware, try all the lil steps like disabling DMA (control panel > system > device manager > find ur writter > propeties).

Short of that a nu top of the line cd-rw is all of £25 these days...and thats for a 52X48X52X i know cos thats what i got and thats the amunt i paid fromn the store. Try

-- moo (, May 26, 2003.

Hi Guys. I don't know whether this will help but here goes.

I have been using Nero for a few years now with no problems whatsoever until recently. I have just bought a Sony DRU-500A and again I had no problems burning CDs or DVD +R/RW but when I tried to burn to DVD -R/RW I got this infernal "SCSI Target Error". Anyway after much research on the 'net (and trying everything under the sun including all the advice in this forum) I came to the conclusion that my old Zip100 ATAPI drive was at the root of the problem. I removed it and it's software as it was now surplus to requirements and I haven't had a problem since.

Therefore for those of you with Iomega drives attached to your system I recommend that you download the most up-to-date "Ioware" from the Iomega site which will not only update your software but your drivers also.

For those of you who do not have any Iomega devices attached there is still something you can do. A number of Iomega drivers are installed when Windows 98 is installed (sorry I can't speak for the other OS's but I guess it will be the same) so you can either go to the Iomega site and download their recent driver update or remove them from your system altogether. You will probably find some or all of the following on your system:

windows/system folder - USBZip.sys windows/system/iosubsys - Afl.vxd, Ddthings.vxd, Iomega.vxd, Ppa3.mpd, and USB_ios.pdr

It's a matter of removing them, rebooting and keeping your fingers crossed. Whatever, Nero is having problems "Targeting" your burner SCSI or not. Therefore if this does not work try removing any other devices that are attached to your system and see if this works. Above all keep your drive's software up-to-date. Nero makes the effort to keep it's software up-to-date after all.

PS - sorry about the email address but I'm trying to avoid being sent numerous emails, abusive or otherwise!

-- Yogi (, June 19, 2003.

For those using 8x 4X 32X burner I have this typeof burner too.Because this burner is low speed,Please ensure that you use CDR or CDRW of 2X-4X or 4X multispeed compatiable. other than that are not accepted. DO NOT use highspeed disc also....If you follow this, should not have any the right burning media next time...

-- T.K. (, August 12, 2003.

hi folks i am also suffering from the same dieases my qsi cd-rw/dvd was working fine i used to burn few cds but then i was getting the invalid write state error i used to have nero software verion 5.5.09 and then i uninstalled and install nero 6 one day i did burn the whole cd properly but ever since started having same problem please help to solve this problem. i also tried to follow some soulution that you all have given but it didnt work i thought my drive have problem the question is if our drive have prob then how can i watch movies and install softwares from cd main thing when burning the data cd it gives the problem please any solution out there that really works i am tired now please help

-- Rahim Manji (, October 30, 2003.

Well i have exactly the same problem...

it started happening completely out of the blue.. ( i suspect windows update personally)

Its not just nero.. its all types of writers (and only nero 5.x on system now)

Its not the drive as i have succesfully burnt all sorts with it in linux, in fact im having to do all my burning in linux (See... windows again... cheif suspect)

Nero wont let me remove its wnaspi drivers, or replace them with proper ones (Its a nero conspiracy)

Has anyone actually tried removing all there burning software and reverting to the built in XP burning software... (I tell you.. its a windows conspiracy...)

Apart from that.. ive tried everything mentioned here, and i still get errors.. will burn to cdrw using incd no problems... but any other burning in XP im having to use cdrw so when it crashes i can try again (not really a lot of use for iso's though as there over the cdrw size)

just waiting for a miracle from God I guess... ;-)

-- dave marsdin (, November 12, 2003.

OK.. after two days solid work I think I have found an answer.. I have just succesfully burnt my first music cd in over a month...

What I did....

------------------------------------------------- Uninstall every single peice of software associated with cd burning

Deleted all directories related to cd burning... including the program directories, users and settings directories, applciation data etc etc etc

Ran a full regclean using regseeker htm


re-ran regclean with regseeker

Backup up my registry

Forced my wnaspi32 back to v4.6 (as opposed to v.4.71) using ForceAspi (software here... (instructions here...

ran a full system defrag in safe mode

changed the DMA mode for the drive to off (PIO) (control panel--->system--->devices--->IDE ATA/ATAPI Controllers--->** IDE Controller)


Installed Nero 6


repeated the process (apart from the full defrag) and installed Nero 5.5.10


Dont know if this will work for others... and it took four hours to do all the defrags etc... But i have now burnt a cd happily (albeit at 4x - will try a higher speed later)

-- dave (, November 13, 2003.

the answer for me is to set to burn as DAO, instead of TAO. problem solved ;)

-- Answer guy (, December 10, 2003.

I get the error Invalid Block Adress wnen trying to write a DVD. Don't know why, and already tried to reinstall aspii drivers and Nero. Aparently I get the same kind of error in DVD X Copy, it gets to 6% and the burn error. My computer is an AMD Athlon XP 3000. My DVD recorder is a Sony DVD RW DRU-500A. Can someone help me?

-- Vasco Cartó (, January 05, 2004.

I cant believe how long this string has been going!!! And still there seems to be many answers, but still more problems. Well here is my problem. When i was using win 98, i had no probs at all, come to think of it i had never made one coaster while using 98, but then i felt compelled to upgrade to xp... then the problems began. I get write errors, at first it just said write error. So i did some searching and found that nero was saying my system aspi was corrupt. so i got a program from a friend and "fixed" it. nero was happy and all was good for a while, but now i get errors that say invalid write state, could not preform endtask. ??? does not happen all the time, not even any regularity to it at all.. some times ill burn 5 or 6 cd in a row no prob.. then one coaster or it will be a couple of coasters .. well u get the idea. i just found this string so im gonna try some of the ideas i found here and report back.. hopefully someday we will find an answer to this problem.

-- Buck Rapp (, January 25, 2004.

I don't Know if this will help everyone but the problems i have had in the past with nero and my burners were all fixed by pluging the burner to the mother board by it's self, don't connect the ribbon to any other cd or hard drive, there was a date flow problem.

after that No problems.

-- Vicky (, January 28, 2004.

Had same prob. - getting loads of write errors/could not perform endtrack - at 99% burn.. but now it's gone. Not totally sure how.

I tried much of stuff here.. espcially changing aspi drivers. But 0 worked. So I went as far as to order replacement CD-RW drive.. (it worked for s.o. else on another forum)

Stopped burning for week, till received drive - but then problem seemed to have cured itself before I changed drives.

One possible solution? - The only thing I'd done meantime was change my firewall - Norman Personal Firewall - which I discovered on another forum, had been causing occasional crashes - especially to do with tdi_rd.sys, (altho Nero had worked fine w that firewall for well over year). Now I have Sygate & everything seems to be working fine. No crashes & I have burned over 30 cd's straight off & no problem.

Mysterious-er & mysterious-er. I'd thought it was my drive that was going, but it would seem not. Was it the firewall change that did it?

Interested to hear comments. [Noticed BTW that many people over the years on another (CD) forum have had versions of this prob. here - But no one over there answered my query about it]

-- andarot (, February 14, 2004.

Very interesting thread. I had the same "End of track" problem as most people above. Very frustrating, but I'm glad to say I am able to burn again! What I did was to delete the wnaspi32 dll in the windows/system directory. Then I installed an aspi32 driver on my Win98 laptop at home. Well, I didn't really know what I was doing ;) But apparently this aspi32 was able to fix the problem. I didn't change anything to my Nero software. I should add that I also turned off the automatic cd insertion in my Control panel. But that's really all I did. As a final note to people frustrated not being able to burn anymore: consider Linux. Distros like Mandrake allow you to easily burn disks without all these problems. (though newbies will perhaps encounter others... dual booting is cool) Good luck!

-- tijs (, February 22, 2004.

I had this same problem with my DVD-RW drive, but luckily I was able to fix it quite easily. I'm using XP and I noticed that my cd-drives were defined as scsi devices. That was wrong. So I clicked update driver on the IDE devices in Device Manager. Reboot. Works perfectly. I hope this works for you too.

-- Jarmo V. (, February 24, 2004.

I'm using XP and Nero Ricoh. As with everyone else, it has worked fine in the past and then I start getting the write error thing.

After reading all the other replies in this thread, I did a search for files with aspi in their name, which turned up winaspi.dll in the Nero directory and ntaspi.dll in my Realplayer directory. I uninstalled Realplayer (don't need it on this PC, got it on another), uninstalled Nero, re-booted, re-installed Nero, re-booted and I've just burned a cheapo CD at 8x with no problem.

-- Robert Smales (, March 18, 2004.

Err. This has been going on for a while. I get an invalid block address error. I made 3 DVDs and then 4 straight coasters with invalid block address errors at only 1% right after the leading in. I will update if I can find a solution.

-- Barton (, April 21, 2004.

I', having a similar problem with my computer at work. I have no Target Error: The case is first Write Error -> all writers idle, stopping conversion -> conversion idle, stopping reader -> Invalid write state -> Could not perform EndTrack. The odd thing here is that this error happens only with big files (400MB+). Burning CDRs with smaller files causes no problem. I'm wondering if anyone else has found this kind of beahiour, good results with CDRs packed with small files, bad results with one huge file.

-- Kimmo Kallio (, June 30, 2004.

I was getting an Invalid Block Address error and a SCSI error using Nero 6.x and a lite-on drive on WinXP. It seemed to only happen at the end of the disk. It was working just fine before. Turns out I plugged my external USB drive into the 2nd USB port (with another device in the first port) some time ago and I haven't been able to burn since.

For me, the solution was to go to Control Panal, Syetem, Hardware, Device Manager, then double click on Primary. My Device 0 was set to use DMA if available, but my Device 1 was set to PIO. Simply switching Device 1 to Use DMA if available and then re-starting Nero solved the problem. No re-boot required.

Good luck.

-- barqs (, January 13, 2005.

Moderation questions? read the FAQ