Canon AE1P in Program mode will not open beyond F2.8 : LUSENET : Canon FD : One Thread

I have had a Canon AE1 program camera for a long time. I recently purchased a used 50mm/F1.4 lens and noticed that when on Program mode the camera will never select an F-stop numerically smaller than F2.8. Then I put my old 50mm/F1.8 lens on and noticed the same behavior. If I select the shutter speed, then it can use an F-stop numerically smaller than F2.8.

Is this normal? Is something broken?

-- Howard Z (, December 04, 2000


Howard, the camera should select all the way down to 1.4 or 1.8, if it's dark enough for the camera to request that much lens opening. Either you're metering too high a light level when trying this, preventing a larger lens opening, or the camera has a problem. With the lens cap on, it surely should indicate 1.4 or 1.8. You can check the operation of the full aperture signal pin by dismounting the lens and gradually depressing the hollow chrome pin in the body next to the stop down lever (it points straight out towards the camera mount). In total darkness, my AE-1P indicates 5.6 with the pin fully extended, stepping down to 1.4 fully depressed. Depress the shutter release half way to activate the camera, of course. If it still displays 2.8 maximum with the pin depressed fully, I'd say it has a problem. Careful not to fingerprint the mirror! And yes, in shutter priority mode, it will select stops all the way to f/1.

-- Alan Swartz (, December 04, 2000.

I just tried with my AE1-P on Program mode with 50mm/f1.4. It does go down to 1.4 even though it is hesitant to go below 2.8. I think the logic reduces speed first then aperture if it's not enough.

-- pil joo (, December 05, 2000.

Well, then it looks like Program mode on my AE1P is indeed broken. Of course it isn't worth paying to fix it.

As I slowly cover up the lens - causing less and less light to come in the fstop goes down to F2.8 and does not go lower - then it will end up flashing at F2.8

At least it appears to operate properly in shutter priority mode.

-- Howard Z (, December 05, 2000.

Can you borrow another lens to try?

The reason is, if the pin on the lens is too short, the camera will not read the real available aperture. It may also be that the part of the camera that reads the aperture is slightly out of spec or dirty.

I would try pushing the pin in completely a few times, GENTLY, to see if that wipes it clean enough to help.

BTW Karl Aimo does a CLA for under $100 I have heard. And I have heard good things about his work.

-- Terry Carraway (, December 06, 2000.

I tried your advise Alan. With the lens cap on and the shutter speed set to Program, the P blinks and 1.4 blinks.

I played with that pin Terry mentioned pressing it in several times. In Program mode the camera can now go down to 2 and even 1.4 however when I point to bad light the P and 2.8 will blink, and when it goes to 2 or 1.4, they blink too.

So it looks like on 'my camera', I can not use Program mode below 2.8

However if I choose the shutter speed I can use 2 and 1.4 without them blinking.

I assume something is wrong with my camera, but I can live with it by always selecting the shutter speed.

-- Howard Z (, December 08, 2000.

Howard, something I didn't consider last month was film speed setting. The tests I tried in my first answer were done at ISO 400. I've misplaced our manual, so I don't have the map the camera uses to select exposure in program mode. As I remember, though (it's my wife's camera--I seldom use it) the P blinks to indicate a shutter speed under 1/30 as a camera shake warning. The aperture blinks as an underexposure warning. In trying it again just now, with the lens capped, stray light entering the viewfinder was enough to make 1.4 stop flashing if I moved the camera slightly away. I still can't quite figure out what's happening with yours, but perhaps that has something to do with it.

-- Alan Swartz (, January 07, 2001.

Moderation questions? read the FAQ