A "silly" question about playing back inps.

greenspun.com : LUSENET : MAME Action Replay : One Thread

Well....I download and watch at inps not so often.....that's why I'm having problems !!!!

That's my situation: my current MAME folder is c:\Games\Mame. I decided to DL an inps for Mame 0.34b3. Got it, and the relevant Mame version. Made a folder c:\Games\Mame\34b3 and put in the mame.exe, and here modified its mame.cfg as follows:

[directory] hi = c:\games\mame\HI cfg = c:\games\mame\CFG pcx = c:\games\mame\PCX inp = c:\games\mame\INP rompath = c:\games\mame\ROMS samplepath = c:\games\mame\SAMPLES

Therefore I put the inp in c:\Games\Mame\inp, and also I deleted the relevant .cfg file in the cfg folder.

Opened a dos box, moved to c:\games\mame\34b3, typed "mame xxxxxx -playback xxxxxx.inp" .


Although the recording appears as confirmed.

What's wrong in what I did!?!? Is there a simpler working way to playback inps!?!

Thanx for the help. Cicca

-- Cicca (cicca@writeme.com), September 01, 1999


When you playback an inp in DOS, you don't need to put the .inp extension for the name of the inp you're trying to playback. For example if you wanted to watch a Kung Fu Master recording, you would type:

mame kungfum -playback kungfum

A more simple way is to use MAME32 for playback, it takes a couple of mouse clicks to play back a game, and is useful to have running in a window with speed throttling on (F10) for those longer recordings.

-- JSW (usagi@dingblue.net.au), September 01, 1999.

I've had problems with recordings losing sync also. At first I thought it was Xmame that had the problem. Then I descovered that Xmame uses autoframeskip as default, I used the command line -noautoframeskip and the games I had problems losing sync would now playback properly in Xmame. Frontline was one of them.

I played BBH's recordings on another game and it lost sync after the 1st level, I then tried JSW's second place recording and it lost sync at about the same point. I played back my recording and it played back fine.

I tried playing back my frontline recording at work with w32.V35 on my NT machine at work and it actual plays the game upside down and does not play back properly. I then played BBH's recording that failed in Xmame on my NT machine at work and it also lost sync after level 1.

It looks like some games are not cross compatible for different platforms amnd/or versions.

PS: Can someone with a dos version test my frontlin recording?

-- Dave Kaupp (info@kaupp.cx), September 01, 1999.

Which frontlin recording is that? did you recently upload any? i had checked with the dos and xmame-36b3 versions of your xmame36b1 recordings and they did not playback. I had also tried to record frontlin in xmame-36b3 and it didn't playback for myself.

I'm finding more and more that frameskiping differences have no effect on playback when using the newer versions of mame, but there are exceptions. tell me which is the recording you want to test or mail it to me and i'll test it.

-- Chad (churritz@cts.com), September 01, 1999.

I jsut played it back with these options. I also do *NOT* have an xmamerc file. After I removed the rc file and used only command line options it recorded and played back fine.

xmame -noautoframeskip -sound -scale 1 -playback /tmp/frontlin-14900.inp

I recorded it in xmame.svga with the same options, without the -scale of course.

Let me know if removing the xmamerc file and using those options works, I played it back with 36b3.

-- Dave Kaupp (info@kaupp.cx), September 01, 1999.

Moderation questions? read the FAQ